All Topics » Pulse Connect Secure



dsclient.error state welcome state failed, error 2 on Linux


dstuffle
Contributor (0)
Sep 19, 2017 12:59pm
I am unable to connect from Linux RHEL 6 command line to the Pulse Secure VPN.


Client info:
executing command : /usr/local/pulse/pulsesvc -v
Pulse Secure client for Linux.
Version : 8.1
Release Version : 8.1-12-Build55809
Build Date/time : Apr 17 2017 21:27:36
Copyright 2016 Pulse Secure

Here is the error from the log on the client side....

20170919083734.55404 pulsesvc[p15682.t15682] dsclient.info



dstuffle
Contributor (0)
Sep 19, 2017 1:01pm
The full error didn't seem to post correctly. Here it is again.

20170919083734.55404 pulsesvc[p15682.t15682] dsclient.info
    dstuffle
    Contributor (0)
    Sep 19, 2017 1:02pm
    20170919083734.55404 pulsesvc[p15682.t15682] dsclient.info 200 (authenticate.cpp:213)
    20170919083734.55413 pulsesvc[p15682.t15682] dsclient.info state: kStateWelcome (dsclient.cpp:319)
    20170919083734.55421 pulsesvc[p15682.t15682] dsclient.error state welcome state failed, error 2 (dsclient.cpp:321)
    20170919083734.56537 pulsesvc[p15682.t15682] ncapp.error Failed to authenticate with IVE. Error 2 (pulsesvc.cpp:250)
    20170919083734.56559 pulsesvc[p15682.t15682] dsncuiapi.para DsNcUiApi::~DsNcUiApi (dsncuiapi.cpp:83)
zanyterp
Pulse Secure Contributor (40)
Oct 5, 2017 5:27pm
Are you doing certificate auth, 2FA, or Host Checker?
armonica
Contributor (0)
Oct 16, 2017 12:03pm
I have the same error too.

I can't connect from terminal on Linux
    dstuffle
    Contributor (0)
    Oct 16, 2017 2:12pm
    I finally got it working. Here is what I did. I'm not sure of server settings as I don't have access to the server.

    Add the full cert chain to the ca-bundle: (we us GeoTrust cert)
    cd /etc/pki/tls/certs
    openssl x509 -in site_cert.crt -text >>ca-bundle.crt
    openssl x509 -in GeoTrustSSLCA-G3.crt -text >>ca-bundle.crt
    openssl x509 -in GeoTrustGlobalCA.crt -text >>ca-bundle.crt

    Use this command to connect. If it connects, it will not come back to a prompt.
    /usr/local/pulse/PulseClient.sh -h -u -r -U https:///launcher

    One thing I'm thinking might have been the issue is that my password started with a special character. After I changed my password to something else it started working.
    dstuffle
    Contributor (0)
    Oct 16, 2017 2:15pm
    This site removed some of the parameters because of the formatting...
    /usr/local/pulse/PulseClient.sh -h VPN_host -u login_ID -r Realm_name -U https://hostname/launcher