All Topics » Pulse Connect Secure



Redhat Linux Kernel upgrade breaks Pulse Secure 8.2R4


rbelsch
Contributor (0)
Sep 29, 2017 1:57pm
Recently we had a kernel upgrade for security purposes from:

kernel-3.10.0-514.26.2.el7.x86_64 (pulse secure worked)

to:

kernel-3.10.0-693.2.2.el7.x86_64 (pulse connects but will not pass traffic)

I thought we had a workaround for this by doing the following:

as root:

echo 0 > /proc/sys/net/ipv6/conf/default/router_solicitations

exit root,

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/pulse
/usr/local/pulse/pulseUi

on a few systems this workaround has worked but recently it's not working on other systems. I'm looking for either a fix to this current issue as we use pulse secure to access our environment from multiple platforms, the only one showing this symptom is Redhat Linux



zanyterp
Pulse Secure Contributor (40)
Sep 29, 2017 6:39pm
I would recommend opening a case if you have not yet done so; I do not believe we have specific kernel support and there may be changes that we need to try and accomodate
    rbelsch
    Contributor (0)
    Sep 29, 2017 8:55pm
    I have never opened a case before, how do I go about doing that?
    zanyterp
    Pulse Secure Contributor (40)
    Oct 3, 2017 4:57pm
    If you have not registered your account at my.pulsesecure.net, you will need to do so and then click on the link for case information.
    You can also call our customer care team at 844-751-7629 and they can open the case and dispatch it to our support team for further investigation and handling
twilson
Contributor (0)
Oct 4, 2017 6:38pm
I'm seeing this same issue.

I just upgraded to CentOS 7.4.1708.
kernel 3.10.0-693.2.2.el7.x86_64

ncsvc -version
Version : 8.2
Release Version : 8.2-5-Build49363
Build Date/time : Aug 25 2016 16:19:10

The client connects just fine, and everything would appear normal. But nothing is actually getting sent out. DNS lookups fail, pinging known valid IPs fails, etc.

The workaround mentioned at the top seems to work for me. But I'd like to be updated on an official solution and a more permanent fix to the problem.
    rbelsch
    Contributor (0)
    Oct 4, 2017 7:48pm
    I just downloaded the latest ps-pulse-linux-5.3r2.0-b853-centos-rhel-installer.rpm from pulsesecure.net and that resolved my issue.
zanyterp
Pulse Secure Contributor (40)
Oct 5, 2017 1:40pm
Thank you for the update that the newest client is working for you